Avatar stephen.wells.18 asked

Unable to remove the title from home page article

I have been unable to remove the title form the homepage article http://smi.successmasterintranet.com.

I have hidden the article title in the main article options and in the article itself but without success. I have also changed it in the menu link article options also without success. This is driving me crazy - how can I get rid of the title article? Thanks.

  • Joomla
  • Vanilla

Edited

23 Answers

21

Avatar michael.maass Support Online answered

Your problem is due to the structure of a certain file in the J! 2.5 installer package of Vanilla, Phoenix and other legacy Warp 5.5 templates. No matter what you had set, the title of the article would always show. This can quite easily be fixed by creating an override for this file, and it should work as expected afterwards.

The following instructions apply to all Warp 5.5 templates that have this problem.

Strictly mind the exact path names where [yoo_template] is the folder of your template (for example yoo_vanilla)!


In the folder "layouts" inside the template folder create a new folder "com_content", and inside that create an additional new folder "article":

templates/[yoo_template]/layouts/com_content/article/

Copy this file

templates/[yoo_template]/warp/systems/joomla/layouts/com_content/article/default.php

to the newly created folder like this

templates/[yoo_template]/layouts/com_content/article/default.php

Open the copied file default.php and look for this line (around line 43):

<h1 class="title"><?php echo $this->escape($this->item->title); ?></h1>

Add one particular line before it and another one after, to make it look exactly like this:

<?php if ($params->get('show_title')) : ?>  
<h1 class="title"><?php echo $this->escape($this->item->title); ?></h1>  
<?php endif; ?>

Save the changes and view your site in the frontend.

If present, this corrected version should then override the frameworks original file. If an article's title is set to hide it should not be shown anymore.


Let me know if this works for you.

Thank you

Edited

2

Avatar christos.kiritsis answered

Yes, this indeed solves the problem, but how about an update to those warp5.5 themes to solve this issue, that made us knock our head to the wall just to hide an article's title ?? ;<

2

Avatar michael.maass Support Online answered

@javier.martin

I have the same problem with the shelf template, warp 6 and joomla 2.5.8.
I can apply the same way?

No, these instructions apply to legacy Warp 5 templates only. You cannot apply them the same way to Warp 6 template and — most important — it will not be necessary. Your issue will most probably be that you used wrong Joomla settings.

Mind that Joomla has more than one place where to make these settings. This is an advantage and offers very detailed options for a set up.

The settings have different priorities and one can override another. It is important to know how the article/s is/are called.

The display of the articles' titles can be set here:

  • Globally: Content > Article Manager > Options [in the toolbar!] > Articles > ...

    This has the lowest priority and will only be used if "Use global" is set for the article and menu item.

  • Per article: Content > Article Manager > [The Article] > Article Options > ...

    Will override the global settings, unless set to "Use global".

  • Per menu item: Menus > [The Menu] > [Menu Item] > Article Options > ...

    Will override the global settings, and that of the individual article, unless set to "Use global". Mind that Blog views like "Category Blog" or "Featured Articles" have an additional settings "Use Article Setting" - which would do just that.

Please thoroghly revise your settings.

Thank you



If this does not fix your issue:

Create your own question (= thread), please.

Do not add further questions to the same question/thread in an attempt to keep hold of people that seem capable or willing to help.

This is not meant to put you off but rather to be able to focus on one issue at a time in order to help you and others with a similar problem.

Thank you

Edited

2

Avatar adonay answered

One year later...

Things are still wrong with all 5.5 warp templates. The solution provided by @michael.maass works, but the template code of an old 5.5 warp template works still better.

template code on version 5.5.14 (latest):

<h1 class="title"><?php echo $this->escape($this->item->title); ?></h1>

poor solution provided by support:

<?php if ($params->get('show_title')) : ?>  <h1 class="title"><?php echo $this->escape($this->item->title); ?></h1>  <?php endif; ?>

template code on version 5.5.11 (more than one year ago, the best solution):

<?php if ($params->get('show_title')) : ?>  
    <h1 class="title">

        <?php if ($params->get('link_titles') && !empty($this->item->readmore_link)) : ?>  
            <a href="<?php echo $this->item->readmore_link; ?>"><?php echo $this->escape($this->item->title); ?></a>  
        <?php else : ?>  
                <?php echo $this->escape($this->item->title); ?>  
        <?php endif; ?>  

    </h1>  
    <?php endif; ?>

Sometimes seems yootheme instead of upgrading versions, downgrade versions...
Please support team, update all templates, remember we are not only paying for latest new templates, we are also paying for the other ones.

Regards

1

Avatar michael.maass Support Online answered

Worked perfectly. Thank you.

Good to read. You are welcome.

Your part now would be to help us to improve this support system: If an answer provided the necessary information to clear your initial issue, use the √ checkmark to the left of it to "accept" it. This will highlight it green and make a solution easier to spot for others.

Thank you

0

Avatar john.baskerville answered

Hello Michael,

I experienced the same issue with the Vanilla template in a Joomla 2.5 installation. Your answer resolved the issue. Great thanks!

Cheers,

0

Avatar dhphllps answered

...and I with Flux, but this fixed it. THANK YOU!

0

Avatar michael.maass Support Online answered

@christopher.acevedo

I checked and looked at the Warp and template files: This step-by-step still fully applies and would work exactly as described above for the current version of the Warp 5.5 template "Corona".

Please make sure you carefully follow the instructions given above.

If this does not work please create a new question on this.

Thank you

0

Avatar tom.krogstad answered

Ah, great! Thanks, I have been browsing Joomla forum for hours on this one, without getting anywhere..

0

Avatar john.connelly answered

michael.maass

one of the best explained solutions i've ever come across in joomla forums...nice work...thank you...

0

Avatar bashion answered

Hello Michael,
thank you for your support. I have managed now to hide my title links.

My site was a fresh installation with fresh YOOtheme download of Spark. Would it be possible, to update the template download with the solution you have posted? I guess this happens only to Warp 5.5.

Cheers, Bianka

0

Avatar javier.martin answered

Good morning
I have the same problem with the shelf template, warp 6 and joomla 2.5.8.
I can apply the same way?
Thanks

0

Avatar aurelio.cerami answered

I am using yoo_flux theme with joomla 2.5.
is possible to hide all the box homepage?

0

Avatar crubio answered

Great work, that worked for the old yooexplorer templete for joomla 2.5

Thanks for the help

0

Avatar cbrueck answered

Worked perfectly on Enterprise template (Joomla 2.5.9 + Enterprise 5.5.13). Thanks a lot!

Know someone who can answer? Share a link to this question via email or twitter.